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   آموزشيهدف ها. 1
ن قـسمت  ی ـبعد از تمام کردن ا.  اول شخص شماستي بازيل کننده ین قسمت از آموزش تکم یا

ک، هـوش  ی ـزیف:  چونیی هایژگی ويد که دارای بسازی اول شخصيد باز ی توان یاز آموزش شما م   
  .ت، باشدیشن شخصیمی و انRagdollدن از نوع ی دشمن، صدمه دیمصنوع

  
  ازهایش نیپ. 2

 قبـل  ي قـسمت هـا  يه ی ـن قسمت بـر پا یا. دیم دو قسمت قبل آموزش آشنا باش    ید با مفاه  یشما با 
  .ساخته شده است

د ی ـم داد و شـما با  یح نخـواه  یپت را توض ـ  ی اسـکر  ي قبـل کـدها    ين آموزش مثل قـسمت هـا      یدر ا 
  .دیق کنیات آنها تحقیخودتان در مورد جزئ

  
  . توسط شماستیاز انجام عملیانگر نی شروع شده باشد ب"-" که با حرف یهر متن: توجه

  
  طیآماده کردن مح. 3

  .م کردی قسمت قبل آموزش کار خواهيما با پروژه 
  ).قسمت متوسطه.( دی خود را باز کنی قبلي پروژه -
  
4 .Waypointها   
 توانـد در  ی را که روبـات م ـ يری شما که مسي ها در بازWaypointست بر   یدمه ا ن قسمت مق  یا

  :می اضافه کني ها را به بازWaypointد ییایب.  کندیا گردش کند را مشخص میآن حرکت 
ک ی ـبـا  ی تقرین ش ـی ـد که ایمطمئن شو. دی بگذارWaypointد و نام آن را یجا کنید ا ی جد ی ش -

  .داردن قرار یمتر بالاتر از سطح زم
 ید کـه ش ـ ی ـد دی ـد خواهیاگر دقت کن. دی اضافه کن ین ش ی را به ا   AutoWayPointپت  ی اسکر -

waypoint به صورت نماد W در قسمت Scene Viewشودیان می نما .  
 شـان  يفاصـله  . ( دی ـط قـرار ده ی در محید و به صورت مثلث   یری بگ Waypoint ی از ش  ی دو کپ  -

  ).اد باشدی زيمقدار



ک را انتخـاب  ی ـن کـار هر ی ايبرا. ریا خینند ی بیگر را م یکدی ها   waypointا  ید که آ  ی چک کن  -
 ( ین افتـــادنیی پـــاي از منـــوAutoWayPoint در قـــسمت Inspector Viewکـــرده و در 

Context Menu (ينه یگز Update Waypointد که اگـر  ید دیحال خواه. دی را انتخاب کن
 شـود  یز رنگ رسـم م ـ بنند، خط سیگر را نبیهمدا به اصطلاح  ی نباشد   ي ا ی ش waypointن دو   یب

  . شودیک خط قرمز رنگ رسم مینصورت یر ایو در غ
د دشـمن  ییایحال ب. می کنی تواند در آن گردش کند را مشخص می را که دشمن ميریحال ما مس  

  .میرا به صحنه اضافه کن
  
   )دشمن( روبات یهوش مصنوع. 5
  .اه کردک روبات دشمن به صحنه اضافه خوین قسمت یا

- Robot Artwork/robot را از Project View    انتخاب کـرده و بـه داخـل Scene View 
  .ن باشدی زمي روبات بالايد که کل بدنه یمطمئن شو. دیدرگ کن

  :می رفتار به روبات بدهيد مقدارییایب
ــه  را WeopensScript/AIپت ی اســکر- ــات اضــافه کن ب ــروب  در Inspector Viewدر . دی

( د یــ آن درگ کني را بــر روFPS Controllerدا کــرده و یــ را پTargetر یــمتغ، AIقــسمت 
  ).هدف روبات

شن روبـات را کنتـرل   ی ـمیپت انین اسکریا. دی ره به روبات اضافه کنAIAnimationپت  ی اسکر -
 یب م ـی ـ ترکAIپت یپت بـا اسـکر  ین اسـکر ی ـا...).  کند و    یک م ی دود، شل  ی که م  یزمان. (  کند یم

 یک م ـیا شـل ی ـ دود ی کـه م ـ یمثلا زمان.  پخش شودیشنیمی چه انیرند چه زمان یگم ب یشود تا تصم  
  . کند تا نرم جلوه کندی اجرا مCrossFadeشن را به صورت یمین انیهمچن. کند

م تـا در  ی بزرگتـر از روبـات کن ـ  ي روبـات را مقـدار  Character Controller ید ش ـیحال ما با
ک کپـسول در اطـراف   ی ـ بـه صـورت   Character Controllerد کـه  یدقت کن. ن فرو نرودیزم

  . شودیداده م روبات نشان
  .ن تداخل نداشته باشدیم تا با زمین کپسول را بزرگتر از خود روبات کنید ایحال ما با

ــاب کن - ــات را انتخ ــت  Inspector Viewد و در یــ روب  Character در قــسمت کامپونن

COntrollerر ی مقادheight و radiusدیش دهیفزا را ا.  



  .دیم کنیق تر تنظیر را دقین مقادید و ای را اجرا کني باز-
 یروبات به خـوب . ک کندی خود شليم که بتواند با اسلحه     ین امکان را بده   ید به روبات ا   یحال ما با  

شن مربـوط  ی ـمی کند، مـا ان یک می خود شلي که روبات با اسلحه     یزمان.  شود یت م یمیحرکت و ان  
 ی روبـات پرتـاب م ـ  ي اسـلحه  ي از مکان لولـه  یم و سپس راکتی کنیا اجرا مک و اسلحه ریبه شل 

شن ی ـمی کـه ان ی زمانی کند و فقط به سادگیشن روبات حرکت نمیمیک گلوله با انیمکان شل . میکن
  . شودی اسلحه پرتاب ميبا از جلویک اجرا شد، تقریشل
  Hierarchy Viewز ا( د ی ـ قـرار ده robot ید و آن را فرزنـد ش ـ ی ـجـاد کن ی ايدی ـ جدی ش ـ-

  ).دیاستفاده کن
  .دی بگزارgun_spawnد را ی جدی نام ش-
 در کامپوننـت  Inspector Viewاز قـسمت  . می مناسـب قـرار ده ـ  يد آن را در جـا ی حال ما با-

transform  ينه ی گزین افتادنیی پاي از منو Reset   را ی ش ـي را انتخاب کـرده و سـپس مقـدار 
  .دی به جلو ببرZدر جهت محور 

 rocket ه  Prefab. دی ـ اضـافه کن   gun_spawn ی را به ش ـ   RocketLauncherپت  ی اسکر -
  .دی درگ کنProjectileر یرا به داخل متغ

 شـود کـه     ین باعـث م ـ   ی ـا. دی ـ بگزار robotد و نـام آن را       ید از روبات بساز   ی جد Prefabک  ی -
  .میجاد کنی ای را به سادگيشتریدشمنان ب

  . کندیک مید که روبات به سمت شما شلیود و مطمئن شی را اجرا کني باز-
دن قسمت بعـد را  ی صدمه ديبرا. ندی بی او صدمه نمید ولیک کنید به روبات شلی توانیز م یشما ن 

  .دیدنبال کن
  
  دن روباتیصدمه د. 6
  .دی را به روبات اضافه کنCharacterDamageپت یکراس -
  .دید کنیه و آن را ناپدد به روبات صدمه زدی توانیحال م. دی را اجرا کني باز-

 EXplosion ه Prefab را بـه    explosion-advancedپت  ی بهتـر شـدن انفجـار اسـکر        يبرا
  .دیاضافه کن

7 .Ragdollها   



Ragdoll  ها ساختار boneيه سـاز یت اسـت، شـب  ی که در واقعيزی اسکلت را به صورت چي ها 
ا پرتـاب  ی ـتـد  فاین ب یبـه زم ـ   یع ـی شود روبات ما هنگام مردن به صورت طب        ی کنند که باعث م    یم

  .شود
  .دیم کنی را تنظRagdoll دهد که چگونه ین قسمت به شما نشان میا

ن ی ـ خـود را در ا Ragdollم ی خـواه یمـا م ـ  ). File->New( د ی بـساز  يدی ـ جد ي ابتدا صحنه    -
  .دیره کنی خود را ذخيصحنه . میم کنیصحنه تنظ

ن مکعـب بـه   ی ـمـا از ا . دی ـر انـدازه ده ییتغد و آنرا اگر لازم است      یبساز ) Cube( ک مکعب   ی -
 کـه در    يد طـور  یروبات را به داخل صحنه درگ کن      . می کن ی روبات استفاده م   ي برا ییعنوان سکو 

  .ردی سکو قرار گيبالا
ن کـار لازم  ی ـا). Inspector Viewاز قسمت ( دی را از روبات حذف کنAnimtion کامپوننت -

  . شودی ميه سازیک شبیزیشن مردن روبات توسط فیمیاست چون ان
  Game Object->Create Other->Ragdoll: دی استفاده کنRagdoll دزاری حال از و-
ن ی ـمربوطـه در ا ) Slot( مناسـب را در اسـلات      boneد  ی ـحـال مـا با    .  شـود  یان م یک پنجره نما  ی
 بـه داخـل اسـلات    Hierarchy View مناسـب را از  boneن کار ی ايما برا. مین کنییزارد تعیو

  .می کنین پنجره درگ میسب در امنا
  .دیدرگ کن) در پنجره (root يرا بر رو) rootHandle)Heirarchy View ابتدا -
  

   ):Leg( پاها 
- Upleg_Lي بر رو Left Hip.  
- Lowleg_Lي بر رو Left Knee.  
- heel_Lي بر رو Left Foot.  
  .دیز تکرار کنی راست ني پاين کار را برای ا-
  

  ):Armا یدست ها (  بالا يبدنه 
- upArm_Lي بر رو Left Arm.  
- elbow_L بر روس Left Elbow.  



- upArm_Rي بر رو Right Arm.  
- spin3ي بر رو Middle Spin.  
  .Head ي بر روhead سرانجام -
  

 ید که روبات سقوط م ـ    ید د یخواه. دی را اجرا کن   يد و سپس باز   ی را بزن  Create يدکمه   -
  . اسلحه اش نهیکند ول

  
  : سقوط اسلحهيبرا
- gun را در Hierarchy Viewدی انتخاب کن.  
  .دی را به آن اضافه کنRigidbody کامپوننت -
  .دی ست کنgunاندازه و مرکز آن را با اندازه و مرکز . دی به آن اضافه کنBox Xolliderک ی -
  

  .میاضافه کن) mass(ت  وزن ید به روبات خصوصییایحال ب
ــاز کن ره پنجــره را دوبــا- و مقــدار ) Game Object->Create Other->Ragdoll( دیــب

Mass دی قرار ده4 را.  
  :می کنی آپلود مPrefabک ی شده را به Rigحال ما روبات 

  .دی را انتخاب کنAssets->Create->Prefab ينه ی گز-
  .دی بگزارrobot-Ragdoll نام آن را -
 شـود  ین کـار باعـث م ـ  یا. دی درگ کنPrtefabن ی به داخل اHierarchy View روبات را از -

  .ز همراه روبات باشدیکه اسلحه ن
 شـده را  Ragdollم و روبـات  ی بـر ین م ـی را از ب ـی که روبات کشته شد، روبات قبل  یحال ما زمان  

  .ردی می مین کار روبات به صورت واقعیبا ا. می کنین میگزیجا
  

  : هاRagdollاستفاده از 
 Hierarchyروبـات را از  ). ستی ـ ني جاري صحنه يره یاز به ذخین( دی را باز کنی اصليصحنه 

View انتخاب کرده و در Inspector View  در قـسمت Character Damage ، Prefab 



  .دی درگ کنdead replacementر ی را به داخل متغrobot-Ragdollه 
  .افتدین میه زمد، بعد از کشته شدن بیحال اگر روبات را هدف قرار ده. دی را اجرا کني باز-

ن کـار  یا.  کار بهتر شوديجه ید تا نتیروبات را اصلاح کن  ) mass(د وزن   یممکن است شما بخواه   
 یمخـصوصا زمـان  . دی ـ همانطور که قبلا نشان داده شد انجـام ده       Ragdollزارد  ید از و  ی توان یرا م 

ار یقـش بـس  ن هنگـام وزن ن ی ـدر ا. که روبات تحت انفجار است و به هوا قرار اسـت پرتـاب شـود          
  . کندیفا می را ایمهم

  
  ):Sound( صدا . 8

  .م کردی اضافه خواهي را به بازی صوتين قسمت افکت هایدر ا
  

  ):MachineGun( ربار ی تياسلحه 
 درگ machineGun ی شــي را بــر روmachineGunSingleShotLoop یل صــوتیــ فا-
  .دیکن
  .دی را خاموش کنPlayOnAwakeت ی خاص-
  

  ):Rocket Launcher( موشک انداز 
ز هنگـام دور شـدن راکـت دور    ی ـن صـدا ن یبنابرا. میم منبع صدا را به راکت اضافه کن   ی خواه یما م 

  . شودیم
- Prefab ه rocketــ را انتخــاب کن ــفا. دی ــاRocketLauncherFire یل صــوتی ــه ج  یی را ب

  . اضافه شودPrefabد تا به ی درگ کنInspector Viewدلخواه در 
  .د تا صدا زودتر قطع شودی قرار ده0,5 را rolloff مقدار -
. دی ـا پـر صـدا کن  ی ـ را کت را کـم صـدا   explotion powerر مقدار یید با تغی توانین می همچن-

  . خوب است50مقدار 
  
  
  



9 .GUI ) يرابط کاربر:(  
. کن اسـت ی بـه بـاز  ي بـاز یت فعلی مسئول اطلاع دادن وضعGUIا به اصطلاح ی ي بازيرلبط کاربر 

، هـدف  ی مانـده، سـلامت  ی بـاق ير هـا ی ـ تعـداد ت :ن عناصر استی شامل اي رابط کاربر  یاصلعناصر  
  ...مرحله و 

  :می داری ما سه عنصر اصلين بازیدر ا
Overlay:  
Overlayریا تی ی کند مانند سلامتیم می را تنظي مختلف رابط کاربري قسمت ها.  

  .دی انتخاب کنProject View را در GUIoverlayل ی فا-
ن کـار  ی ـا. دی را انتخاب کنGame Object->Create Other->GUI Texture ينه یز گ-

  .ردی قرار گGame View در مرکز ی شود که تکسچر انتخابیباعث م
  .می از صفحه قرار دهی مناسبي را در جاOverlayم تا یاز داریحال ما ن

- transform دی قرار ده0 0 0 آن را.  
  ).Xmin Ymin Xmax Ymax. ( دی قرار ده0 0 256 128 را Pixel Inset مقدار -
  

  ):Health ( یسلامت
  .دی انتخاب کنProject View را از GUI->healthbar تکسچر -
  .دی را انتخاب کنGame Object->Create Other-GUI Texture ينه ی گز-
  .دی کن0 0 0 را transform مقدار -
  .دی کن37 83 148 112 را Pixel Inset مقدار -
 را یکـون سـلامت  یط کنـار آ یر اندازه خواهد داد تا مح ـ     یی تغ ين باز ی در ح  healthBar تکسچر   -

  .پوشش دهد
  

  :ربازی تياسلحه 
  .دی را انتخاب کنGame Object->Create Other->Text ينه ی گز-
- Transform دی قرار ده0 0 0 آن را.  
  .دی کن188 109 را Pixel Inset مقدار -



  . کندیر میی تغين بازیر حال در حه به ید ولی را عوض کنTextن ی اد متنی توانیا ممش
  

  :راکت ها
  .دی انتخاب کنProject View را از GUIRocketل ی فا-
  .دی را انتخاب کنGame Object->Create Other->GUI Texture ينه ی گز-
 را در قـــسمت GUIد و یـــ اضـــافه کنFPS Controller را بـــه FPSPlayerپت ی اســـکر-
  .دی قرار دهFPSPlayerپت یسکرا

  
  :در انتها
  :می را اضافه کنيشتری بي مقدار صداییای بیم ولیبا آموزش را تمام کردیما تقر
  :کنیدن بازی صدمه ديصداها

  :دیر را اضافه کنی زي صداهاFPS COntroller اضافه شده به FPSPlayerپت ی به اسکر-
- moanOfPainSmall  
- moanOfPainBig  
- PlayerDie  
  

  : قدم زدنيصداها
 از ي دوريبـرا ( م ی اضـافه کن ـ FPS Controller قـدم زدن بـه   يم هـر تعـداد صـدا   ی توانیما م

  :ست هستندی انتخاب شده از لی تصادفينها منتخب صداهایا).  شدنيتکرار
- FPSPlayerمثلث کنار . دی را انتخاب کنWalk Sound دی ـ کن5ز آن را یسـا .دی ـ را بـاز کن .
  .دیجاد شده اضافه کنی عنصر ا5 يب برای را به ترتfootStep1-5 یت صويل هایفا
  .ستیاز نی نيگرین و کار دیفقط هم. دی اضافه کنFPS Player به Audio Sourceک ی -
  

   متحركيای اشي برایینورها
 ي نـورپرداز يافـزار مدلـساز    قـبلا در نـرم   یعنیشده است   ) Lightmap( ت مپ   یلا ما   يصحنه  

ک ی ـنامی انداخته شده است و بـه اصـطلاح دا  ی شيا محاسبه شده و بر رو     ی اش ي هیشده است و سا   



 تواننـد اسـتفاده کننـد چـون     ین نـور نم ـ ی ـ از اي بـاز يت هـا  یاء متحرك و شخـص    یپس اش . ستین
ت ی ـه لایر بگزارند و شبیاء تاثین اشیم که فقط به ایجاد کنی را ايد نوریپس ما با.  کنند یحرکت م 
  .می کنیت خود استفاده می ه لاculling maskت یصف ما از خان هدی ايبرا. مپ باشند

  .دیجاد کنی اDirectional Lightک ی -
 یر م ـی بـر آن تـاث  Directional Light را که يزیم که چی کنی استفاده مculling maskما از 

  . کندیارد را مشخص مذگ
 را انتخـاب  User Layer 8. دی ـ بروEdit->Project Setting->Tags ابتـدا بـه قـسمت    -

  .دی را وارد کنlightmappedکرده و مقدار 
  .دی را خاموش کنlightmapped ينه ی را انتخاب کرده و گزDirectionl Light حال -
ر ی ـی تغ lightmapped آن را بـه      Layerت  یخاص ـ. دی را انتخاب کن   mainLevelMesh ی ش -

  .دی را بدهyesده شده پاسخ یبه سوال پرس. دیده
  

  ...وم شد بود تمیهرچ
 آورده شـده در سـبک   يک هـا ی ـ از راه حـل هـا و تکن  یلیخ. آموزش اول شخص ما هم تموم شد     

م کـه شـما   یداری ـما ام. ستی شود و مختص سبک اول شخص ن      یز استفاده م  ی ها ن  يگر باز ی د يها
 Unityبـا و فـوق العـاده بـا     ی زي هـا ين به بعد بازید و از ای آشنا شده باشي ساز ي باز يه ها یبا پا 
  .دیازبس
  

  :يسپاسگزار
ن ی ـف ای تـال ي کـه بـرا  ی کمکيبرا) کیگراف( و اتان وسبورق ) کد( م آنته یسپاس فراوان از جوچ   
  !!!! کنندین مطلب را ترجمه می که ای کسانين تشکر فراوان از همه یکتاب کردند و همچن

  
  دلها و قلوب ی متعال و مهربان و شافخداونداد و ذکر یبا 
  
  
  



  



  
  


